+8

Sharp Increase in Phantom Drain since 2019.5.x - Vehicle Not Sleeping

golanbenoni 1 month ago • updated by kur0sak3 2 weeks ago 37

Has anyone noted since upgrading to 2019.5.x that their Model 3's are no longer sleeping?  I am loosing between 1-2 miles of range per hour since we updated to 2019.5.15 on March 12th and have not yet seen the car sleep.  Members on other forms claim that they've had to change their Tesla Passwords and invalidate the API keys as a work-around in the meantime.  Time to Try Sleeping (15), Idle Time before Trying to Sleep (30), Try to Sleep Requirement (No Shift State), Nighttime TeslaFi Sleep Mode: enabled btwn 10PM-8AM. 



I've opened a private ticket yesterday, but curious to know what the folks on the forum are seeing?

I'm noticing the same on my MX, however I also had the Enhanced Anti-Theft system installed at the same time. My car's now been idling for 8+ hours in the parking lot at work. I'm going to see what happens if I disable the enhanced anti theft system tonight at the house to see if it goes to sleep at its normal cycle (2 hours)

Are you on 2019.5.15?  This occured to us after updating from 2018.50.6.  I should note that this occurs when Sentry Mode is disabled.

Yep I’m also on 2019.5.15, previously on 2018.49.20.  2018.49.20 was working fine and the car would normally take no more than 2 hours or so to go to sleep. 

i saw the same thing.  Not sleeping for 3 days.  Then I changed my Time to try sleeping from 5 to 12 minutes and that seems to have helped mostly.  There are still a few odd things happening like today after checking with the Tesla app it showed offline for TeslaFi for the remainder of the day.  I have used Sentry mode twice - yesterday and last week once.  Seems to really throw things for a curve ball now.

I tried setting my time also to 15 from 5, and doesn't seem to have helped unfortunately. Although the car never went to sleep last night even though "deep sleep" was enabled in TeslaFi so it wasn't polling the car at all. 


Google Wifi did show the car sending data every hour last night. Not sure if it's phoning home and sending logs or what's going on but I'm assuming its a Tesla Software thing rather than TeslaFi given that it refused to sleep while TeslaFi was in Deep Sleep mode. Maybe I'll try resetting my password and kick off "Stats" to see if that helps. 

I'm also seeing some behaviour where I take a drive, the car goes through one 12 minute "Trying to Sleep" cycle, then shows offline in TeslaFi until I go back to the car.  Very strange.

I have an interesting observation; which is that I can get the car to sleep, if and only if I set my SOC below the current charge levels. Ordinarily, I charge up to 90% while at home - in the most recent code update, the car never falls asleep after hitting 90% - the car goes through what appears to be more frequent charging cycles. I suspect that there is an interaction between this new charging algorithm, the API polling, and sleep cycles. In my test, I lowered the target SOC to 80% (10 percent higher than my current SOC) and the car finally went to sleep. The API logs indicate the car is "offline" usually within an hour or so of parking the vehicle.  In this release, when the car finally does go offline, it never passes through "Idling->sleeping" phase - rather it simply drops offline.  Before I lowered the target SOC, the car would go through a never ending loop of sleep attempts, and sleep failures while plugged in and charging.

Here is an example:

Here is what it does now after lowering the target charging levels below current SOC:


 Can anyone else replicate this test?

Just an update; I just realized that this method does not always result in the car falling asleep.  The last attempt failed, with the same general issue.  I even extended the length of time TeslaFi gives the car to sleep from 15 to 25 minutes.

According to my TezLab stats, I've lost 311 miles of range this month due to phantom drain, with the vast majority occurring in the last 10 days (since I updated the software to 2019.5.15). At this rate, I'm on track to losing 900 miles of range this month, which sounds completely absurd. Either the statistics are incorrect, or we have a major issue here.  



I'm going to open a case with the Tezlab team to have a look since it just doesn't seem right.  (It is scheduled not to poll between 8pm and 5am).  


So far I have not seen a response yet to the TeslaFi suport ticket after I opened my case, and I hope they get back to me soon.


I noticed last night (between approximately 12 AM and 4 AM) that the car was waking up every 1hr15mins to charge, something I have never seen before. It finally settled down to sleep at 4:30 and it has been sleeping since.

As a test this evening, I'm going to disconnect charging power and all API's from the vehicle and let it stand alone for 24 - 36 hours and manually calculate phantom drain.

golanbenoni I was going to suggest changing your Tesla password to rule out all APIs.  I’m beginning to think this is tied to the new Sentry code.  Thankfully tinkering with my TeslaFi settings seems to have fixed mine.  Others who have tried the same settings as me however don’t have as much luck.  With so many people looking at this I’m hopeful it will be resolved soon.

can someone tell me what is the optimal teslafi setting to minimize vampire drain. I see notifications that the car goes to sleep every 15 minutes. Ideally, I would like it to be only a few times per day and then it goes offline. 

I've disabled all API integrations (with the exception of the Tesla native App).  Last night, I had only 3 miles of phantom drain over a 24 hour period (manually calculated).  The developers over at the Tezlab team told me yesterday that they suspect the phantom drain numbers may be incorrect, and may be calculating some of the drain as part of actual drives consumption.  In the mean time, I'm going to leave the App integrations disabled while I calculate several days of phantom drain numbers.  One user commented on another forum that they left TeslaFi running, but disabled their Stats App and were able to get their car to sleep normally.

Removed Stats access yesterday by changing password but I was out all day yesterday. Got back to the house with TeslaFi on deep sleep from 8:40pm to 7:18am when I decided to check in on the Tesla app to wake it up. Looks like it went from 229 - 223.35 (rated). Still no sleep status registered, but it did go offline for about the last hour and a half. 

+1

@golanbenoni My TM3 has also been re-charging the last ~1% every hour or so (79%/80% -> 80%). IIR, this started at some point while I was on 2019.5.15, and has continued with 2019.8.3. It does seem to stop once my car has gone to sleep, either on its own during the day, or after 10pm (Sleep Mode setting in TeslaFi).

I should mention I only started using TeslaFi on March 10th, and updated to 2019.5.15 on March 11th, so I do not have enough data to correlate this to specific versions. The first instance of this occurred for me on March 18th.

I think this is definitely a 5.15 bug. We don’t have Sentry on and it started the night we loaded 5.15. We have a new update waiting (probably 2019.8.3) and we will see if that stops it. It has nothing to do with TeslaFi at all. 

I installed 2019.8.3 Tuesday night (March 26), and noticed this issue the following day. If it is a Tesla bug, it doesn't appear to be fixed.

Wonderful... saw that above, also. I assume Tesla knows but has anyone gotten a response from them? I’ve not seen a definitive answer on TMC or elsewhere. 

My sense is this is more of an interaction between the new Charge - Sleep Cycles since 2019.5.15 and TeslaFi polling.  Tesla has a tendency to change things without documenting them which can be challenging for anyone developing services against their APIs.  It would be nice to hear from TeslaFi; they've been pretty quiet about this since reporting the issue two weeks ago.

One thing I've done, as part of cost savings measures is to charge my car only off-peak.  (I subscribe to a Smart Charge Rewards Program, available in NYC where I can get .10kw back).  I simply configured my car to charge only after midnight, and this seems to resolve some of the issues with the frequent charge cycles during the day.  In the meantime, have not re-enabled TeslaFi, or any of my other Apps in close to a week while these issues are being worked through.  I still get relatively solid stats from my OBD2 device so I'm not completely without data from the car.

what OBD2 device are we talking about?

See: https://www.fleetcarma.com/chargethenorth/ - I got this as part of a Smart Charge Rewards program which emphasizes and rewards (cash) for off-peak charging.  I paid nothing for it, installed it in about 10 minutes, and get the following stats (ignore Gas consumed, and Electric Distance Fraction): 

Start Date, End Date, Duration, Distance (mi), Electricity Consumed (kWh), Fuel Efficiency Equivalent (MPGeq), Electricity Driving Efficiency (Wh/mi), Starting SOC (%), Ending SOC (%), Aux Load (kWh), Ambient Temp (F), Smooth Acceleration (%), and Smooth Breaking (%).

Vehicle Model

Start Date

End Date

Duration

Distance (mi)

Gasoline Consumed (gal)

Electricity Consumed (kWh)

Fuel Efficiency Equivalent (MPGeq)

Electric Driving Efficiency (Wh/mi)

Starting SOC (%)

Ending SOC (%)

Electric Distance Fraction (%)

Auxiliary Load (kWh)

Ambient Temperature (F)

Smooth Acceleration (%)

Smooth Braking (%)

I'm seeing this issue with both 2019.5.15 and 2019.8.3.  Yesterday I disabled TeslaFi polling completely and the car did go to sleep (when I opened the app after a bit, I got the "waking up" message).  I changed the sleep timer from 5 to 15 and re-enabled polling, but it's back to not sleeping again.

I have not reenabled TeslaFi for approximately 10 days (along with other 3rd party Applications).  It seems my car has been sleeping normally since then.  I'm hoping the developer will provide some meta-analysis here across builds, vehicles and settings.

I ended up bumping my time to sleep from 15 to 20 minutes and it seems to fall asleep easier now.

I’ve also scheduled my charging to start at 10pm which is after when the Teslafi nighttime sleep mode is enabled. This has stopped the frequent 1% recharging notifications. Not really a fix, just a work around. 

I'll give that a shot, thanks

Setting the delay to 20 minutes (then 30) didn't work for me either, unfortunately.

Having exact same issues. Started with 2019.5.x and now on 2019.8.3. When I disabled polling and changed Tesla password immediately stopped having issues. Hope TeslaFi can fix!

We are finding that with the last couple of software updates, weird things are happening to the monitoring of our Teslas.  If we turn off monitoring entirely for a period of a couple of days, we are finding the battery range / capacity is actually adding miles instead of draining.  This would seem to indicate that the phantom drain display we are seeing monitoring the API is not entire "real" and partially due to bad calculations on Tesla's end seemingly caused by the monitoring in the first place.

We first saw this while troubleshooting with Tesla why we couldn't charge our cars to 100% (maxed out at 93% for example).  When we turned off monitoring for a day and let the car sit, it actually started at 90% and by 12 hours later it was reading as 94% battery left on the app (opposite of phantom drain).

If this "bug" is more wide-ranging, then I would suggest that any phantom drain numbers being seen through any monitoring app are likely incorrect and you might consider turning off all monitoring (e.g. reset your Tesla password) and seeing if you see similar behavior.

To be clear, that was 90% unplugged to 94% unplugged after about 12 hours...  That would seem to suggest that the car was really sitting somewhere near 96% and during those 12 hours we both had some phantom drain, but also a reset in the calculations that the car was using to judge the remaining battery.

Not sure why, but after the update to 8.3 my car has gone back to sleeping normally which is after being idle for about 2-2.5 hours. I currently have sleep time to 15 mins and to attempt after 15 mins of idle. Weird, since I know others are still seeing issues even on this version. One thing to note is that TeslaFi is also the only third party to be connected to my account. 


Other things I might recommend folks trying is also turning off background app refresh, or having any widgets enabled that could be triggering your phone to wake up the car. Shot in the dark but maybe worth trying as well.

I attempted to re-enable TeslaFi today (not not Tezlab) to see whether there has been any recent change in behavior.  I am still running 2019.8.3 - unfortunately - I'm continuing to have an issue with getting the car to sleep, as can be seen in the raw logs below.  We tried and failed approximately every half hour for the last several hours.

Any update from the developer would be appreciated.

An Update: I believe there may be a race condition between TeslaFi and other Apps, which may mean this has been self-inflicted.


I've spoken to the developer of another App (TeslaMon), who stated:

So there is only 1 way to tell if the car is asleep or awake that doesn't disturb a potential sleep.


However, when trying to put the car to sleep, you give up on monitoring if the car is driving or charging, because if you check if the car is awake, you then have to check what it's doing. 


IF you check what its doing, it will reset it's time til sleep, keeping it awake.


So TeslaFi and TeslaMon have parameters, time to stay in bed, and time to sleep like you explained in one of your TeslaFi bugs.


If our cycles are off, such that TeslaFi is 'trying to sleep' and TeslaMon is 'checking to see after trying to sleep' then it resets the sleep, causing the car to never sleep.

While there may be another issue with interactions between TeslaFi and TeslaMon, I only use the former and still have this no sleeping issue.

Same here. I signed out of Stats and my 3 still won't sleep. Not sure what TeslaFi is doing, but its def the cause of keeping my vehicle awake.

Sometimes just signing out isn't enough to guarantee an app has stopped pulling data, sure fire way is to change your password completely on Tesla.com. Then you can log in only to the Tesla mobile app, and see if after a few hours when you launch the app if you get the "waking car" notification which tells you your car was asleep. 


If that ends up working, I would then add just one third party app and use it like you normally would. If it stops sleeping then the third party app and its setting may be keeping it awake. 


However if you never get it to sleep with only the Tesla native app connected than something else is keeping it awake.

Sorry, should of been more clear. When I said signed out, I meant I changed my password to ensure it's logged off. I'll do the same again for TeslaFi as well to see if I get the waking up message from the TeslaFi app.

Ahh gotcha, no worries at all. Good luck! Definitely give it a few hours before checking in on it though. I noticed my car wouldn't sleep until after 2-3 hours during the day.