+3

Model X rarely sleeping since 48.12.1

bigriver 3 months ago • updated by alechenne 1 week ago 22

My model X (100D, Sept 2017 build) usually sleeps for more than half the day and vampire drain is usually around 1%, as expected.  For the past week (since firmware was updated to 48.12.1), it has rarely slept -- going without any sleep for 4 days, and twice sleeping for about 7 hours each time.  The vampire loss is at about 3% per day.  Sitting in my garage in the mid-50's F.  My model 3, sitting right next to it and on same firmware version, has had no trouble sleeping and vampire losses are low.

I've changed my Tesla password and generated a new Teslafi token to ensure there is no other app accessing the car.  I've rebooted the car.  We are keeping our Tesla app closed on the phones.  I believe I have all my Teslafi sleep settings the same as I've always had them (except I have now played with stop polling for 30 minutes and only wait 10 min of idle before trying again.)  All 3 boxes are unchecked under the Try to Sleep Requirements. On the car settings, Energy Saver is on, always connected is off, and there is no pre-conditioning nor overheat protection.

As I understand that Teslafi can't make the car actually sleep, it can only suspend polling to facilitate sleep, I would think something is amiss with my car.  However, I totally suspended all logging by Teslafi last night for over 11 hours, and when I resumed this morning, there had been a loss of only 1.2 miles -- which is great!  This makes me back reconsidering whether I need to make further adjustments in my Teslafi settings.

I am wondering if any one else is experiencing this?  Are there any new changes I should make to my settings for the Model X due to the latest firmware update?

Hello, I've exactly the same trouble since mid of Dec. when I installed the 48.xx firmware release. But I don't know if it's related to that. I've also a X model (march 2018). I checked the settings of Teslafi comparing to a S Model (with the same firmware) I had by the past (Sept. 2017) and the settings are the same. I don't understand at all that is happening because sleeping was ok prior mid od Dec. I noted that the car nevertheless goes in deep sleep according to the log of Teslafi.

Any help will be very appreciated.

It it possible which is related to the dash cam; I always a USB stick connected in the car to store the dash cam videos. Normally, when stopping the polling, it has to stop the dash cam trafic too but ?

Additionnaly, after checking the TeslaFi log (raw data), I noted that:

- My car is going in deep sleep mode as expected (e.g during the period indicated in the settings)

- My car is trying going in sleep mode as expected (e.g during the period indicated in the settings) but most of time (nearly all time) is failed sleep

I'm having the exact same issue in my Model x since firmware upgrade. I lost over ten percent last night's from drain. It was only 8 degrees outside. But still a large loss. Any news on what's wrong? 

Outside at 8 F and losing 10% sounds like the battery is snowflaked from being cold, and that "loss" that shows up in the Teslafi log is only temporary.  It will return when the battery warms up, but won't explicitly show as such in the Teslafi log. It will just show that the drive used fewer rated miles, and thus the efficiency of the drive will look phenomenal.

I'll also update on my original post..... my car is essentially sitting unused and has developed a very good pattern with very little losses.  It sleeps for approximately 4 days, wakes up for approximately 12 hours, then goes back to sleep.  The vampire losses are very small -- less than 1 mile per day.  I do not know what changed, but all seems well now.

Hey, i'm not overly concerned about the loss as much as i'm concerned about it never going to sleep anymore post the update.  I've tried the various settings the original poster mentioned but the only yields about 1 hour of sleep even though the vehicle is idling.  

I'm in a 2016 Model X.

Yesterday (Sunday Jan. 27th), for the first time since I updated to the release 2018.48.12.1 d6999f5 on Dec. 21st, my X Modell was indicated as sleeping during the night. The period is strange because it was during the night, during the period it has to be in deep sleep. Anyway, as mentioned by somebody else, without touching anything (no new firmware release, no change in the TeslaFi settings), TeslaFi is another indicated sleeping periods. I noticed that the TeslaFi datalogger has been update 2 days ago, but according the releae notes, nothing seems related to the sleeping issue. Anyway, I'll check the coming days to understand a little bit better the behaviour of the sleeping and deep sleeping modes. It seems that issue was impacted only the X Model because my S Model, with the same firmware and same setting was indicated the sleep periods as usually. May be James of TeslaFi will update this post in order to explain us that was the issue.

 

Same story here with 2018.48.12.x.  Car started not sleeping and also messing up charging via HPWC (because always being awake).  It would never 'try to sleep'.   (2017 Model X MCU 1)

Checking all settings, it's not always connected, energy savings on, new token, etc.   Never been a problem for over a year. 


So, I turned off the 'check for no temperature' settings and it immediately started 'letting sleep'.  It seems like those settings may have changed at 48.12.

Now it never reports sleeping after repeatedly trying to sleep.  Also changed the time from 15 to 30 minutes, no change.  If these settings are disabled, how can the software tell the car is asleep?  If it's checking these temperature settings, they are gone.  So, what are we actually doing here?  Sorta confused what we are looking for here now....

At this point, I have no idea how TF is actually working in checking for awake or asleep if those are the only things checked. (Also had a USB stick for dashcam, removed it, no effect.)

Thoughts?

Added info:  looking at the API data, I noted that the only one of the three data points that actually ever 'disappears' was the Shift state. The internal and external temperature never did.  So, I'm trying having ONLY that one enabled to see if that might work as a trigger for 'sleep ready'.  But it doesn't disappear often which doesn't make sense.  Car is idle all day/night.

Jeez....  :)

Some additionnal info: since I wrote the first post on this topic, sleeping mode was activated from Jan. 27 up to Feb. 11. Since Fab. 12, sleeping isn't working anymore. Teslafi settings are always the same and I don't get any software release in the my Model X. But the deep sleep mode seems even working correctly (even when I wrote the first post). 

What I've analyzed is: 

- when sleeping come back, the activation wasn't as predicted, a little bit random (on/off). What is also strange, is that when in deep sleep mode, connection state is "online" ??? When sleeping mode is working and active, connection state is "asleep". What is curious, is that normally "deep sleep" mode is a more advanced state (in terms of reducing the consumption of the car, meaning deeper sleeping mode) than "sleep mode". Normally, but it's my understanding, in deep sleep mode, there is no connection with car, no polling.

- even when deep sleep mode is activated, loss seems to be beetween 14 up to 21 km / day. When sleep mode is working, it could be reduced to 5-7 km / day. 


It would be great if someone in the group could explain how Teslafi is handling sleeping and deep sleep and how the loss are calculated.

Definitively, something is strange since the 2018.48 release in Dec. 2017.

I have exactly same firmware (Canadian Car but currently using in DE, 50F temp) and exactly same problem 

Disabling Teslafi will let the car sleep but I’m pretty sure the sleeping pattern has got changed 

No idea how to tweak but looks like any api call will wake up the car... 


Need help for it... daily drain is about 3% for me... 

New firmware 2018.50.6 4ec03ed installed on Feb. 16th. Not a lot of expérience, but the last, and this nght, car seems to enter in sleep mode correctly. I'll come back later after few more checks.

@alechenne

I just got the same firmware today, what's your settings inside the TeslaFi sleeping settings?

I tried disable TeslaFi completely overnight, and it does sleep properly, with the old firmware, it does not. 

Dear All,

Coming back on my last experience on that topic. Since I installed the firmware release 2018.50.6 4ec03ed. it seems working better now. My car (a Model X of March 2018) is sleeping over the night. The battery loss seems to be returned to correct values. Nevertheless I still don't understand the logic and the behaviour of the "sleep" and "deep sleep"  according what I saw on the raw data and according to the settings. It's still seems very strange, Anway, here are my seettings:

I'll continue my investigations and keep you informed.

Kind regards.

    Do you have MCU2?

    The sleeping behavior is different for MCU1


    Mine is 2017 Model X with MCU1, 

    I found it only sleep approximately midnight to 4am


    Comparing settings, I don’t have deep sleep on, I may try that to see if it helps... 

    My Model X was delivered in Switzerland at the end of March 2018, so I suppose production date was early 2018 (in January or somethiong like that). I would say MCU1. If I test it through https://teslatap.com/mcu/, it displays effectively MCU1.

    Kind regards

    The issue seems solved. My X modell sleeps again correctly during the evening and even sometimes during the day. I don't what has been changed. I got 2 firmware release within 20 days, 2018.50.6 4ec03ed on Feb. 16th and 2019.5.14 53ca475 on March 1st. Since now a week, the behavioour of the sleeping mode seems ok. Hope it will remain stable. Kind regards.

    @alechenne,

    do you still have the TeslaFi Settings try to sleep requirements all unchecked?

    Hello,


    Yes, all the 3 Try To Sleep Requirements checkboxes are unchecked in my settings.

    Kind regards

    I am on 2018.50.6 now and my car never sleep in the day.

    In the night, after the deep sleep time (0 to 5am for me), the car automatically wake up around 6:30am

    My garage is about 5C and outside is about -2C

    maybe the weather keep the car awake? 

    Hello, I think the issue is related to firmware: from 2018.50.6 4ec03ed up to 2018.50.6 4ec03ed, it seems the behaviour wasn't good (e.g don't go in sleep mode, and with 2018.50.6 4ec03ed, sometimes but nothing logic). It return back to correct behaviour when I switched on FW 2019.5.14 53ca475. Kind regards.