0
Not a bug

Map Error in Emailed Trip Summaries

mkolowich 3 years ago updated 3 years ago 9

Route traveled during a drive is no longer displayed in emailed drive summaries.  Instead, the map shows pins at origin and destination, and a notation "Map error: g.co/staticmaperror appears in the upper right corner of the map.  See attached screen shot.


Yup -- all emailed drive summaries since the email change seem to be fine.  Thanks for giving me the clue that solved it!

Not a bug

Thanks.  I'll close this but you can reply if needed.

I have a feeling that the email change solved it.  First drive came out fine.


My TeslaFi account is registered under a forwarding email address that forwards to Gmail.  Now, I've put the Gmail address directly into the Notifications address.


The forwarding must have affected the Google maps rendering.


I have a half-dozen long drives this weekend to Northern New England, and so I should be able to test this thoroughly.

No, but I'm going to try that now.  It's strange -- problem seems to be intermittent.  80% of the time I get the error, but other times not.  For example, Drive 3312 displays properly:


...but Drive 3314 does not:


Will change email address as experiment and see what happens.  I have a lot of long drives this weekend.


Michael

Were you ever able to try changing to a different email address to see if this issue still occurs?

Strange.  I copied your emails to another email account and they all came in fine for me including that one.


Can you send the email to support@teslafi.com?  Try attaching it instead of forwarding it so I can see all the data behind the scenes.


Thanks


Still seeing error last night:

Hi,


Did you see any errors in the emails yesterday?

Started

Hi,


I'm not sure what is causing this.  The maps seem to be appearing on the website correctly and my drive emails are working correctly.


I enabled some logging on the email script for your account.  I'll wait for some drives to come in and see what it says.


Thanks,


James

Commenting disabled