0
Not a bug

Share link just goes to shared drives page

Infraded 1 year ago updated 1 year ago 9

Clicking on the share link next to a drive just redirects to the Shared Drives page with nothing on it. This happens with the share icon on the summary page and the drive details page.

Under review

Hi,


I can't seem to be able to duplicate this.  I tried safari and chrome but the following pages seem to work by creating the shared drive when it redirects you to https://www.teslafi.com/sharedDrives.php.


https://www.teslafi.com/index.php

https://www.teslafi.com/dayDrives.php?driveNumber=115


What browser are you using so I can try it?


Thanks,


James

I've tried from both Chrome Canary and FF Nightly on OSX and Windows from work and home, but get nothing but a redirect to the Shared Drives page (with no shares) in all cases. Have also tried fresh builds and incognito/private windows with no other sessions.

Can you try regular chrome and see if it works?  I don't understand why it wouldn't.   It's a simple html form.  Can you also send a screenshot of the page it redirects you to?  


Does it show this?  Or is it just blank?


That's the page I get, with just the instructions. Tried from Chrome v68 and it works there. Really interesting that it doesn't work in either browser's nightly builds though.

Comparing the requests from both Chrome versions, the latest doesn't include the `submit: share` in the POST form data.


Edit: That param is also missing from the request from FF Nightly.

Not a bug

It's probably an issue with recognizing images as an input type.

Yeah, looks like it's technically out-of-spec to include value with an input type of image. https://www.chromestatus.com/feature/5672688152477696 and they've fixed it.

+1

I went ahead and changed the few image input types in the drive tables that had values so they should work now.

Looks good in both browsers now. Thanks!

Commenting disabled