+1
Under review

Sleep with New Intel MCU

mknox 11 months ago • updated by Parv 5 months ago 20

My couple of week old Model X came with the new Intel based MCU. As such, it does not have the Energy Savings options like older cars have... just white space where they would have been. Tesla says energy savings are "automated" on these newer cars. How does TeslaFi Sleep work on these cars, or does it work at all?

I was told sleep doesn't currently work on the new mcu, but may be fixed in a future firmware.

-1

Not quite. This is what the Owners Manual now says about it:




+1

I am specifically taking about sleep in Teslafi.  The dev told me it doesn't work at all currently on MCU2 cars.

Ahh, okay. When you said "fixed in a future firmware" I assumed you meant the car's firmware.


TeslaFi does show my car periodically sleeping, but it seems to be at kind of random times and "wakes up" at weird times. I don't know if this is Tesla's doing or whether TeslaFi is somehow waking the car up.

Hi,


Sorry for the delay.  The sleep mode does not appear to work in the same way that it used to with the new MCU.  


However, you'll notice that your vehicle reports as 'offline' while idling in https://www.teslafi.com/data.php.  When the vehicle reports as offline TeslaFi halts any polling of data and does not 'wake' the car.   Model 3's were doing the same thing at first release but have since started to report as 'asleep' after a little while of idling with the newer firmware versions.  I'm guessing the same thing will happen with the new s and x's with the mcu's soon.


Overall currently the offline while idling is not bad since it keeps TeslaFi from polling the car when idling and lets it sleep.  It also prevents any data loss since TeslaFi will catch when the car is changing states because it doesn't have to pause polling to let the car sleep.  The only downside is that it doesn't register sleep sessions due to the fact that the API doesn't currently report 'asleep'.  But again I think this will change like the model 3 did.


We'll just have to keep an eye on it.


Thanks,


James

+1

Thanks James.


In case it's of any help, I occasionally, but very rarely see my car "Sleeping" in TeslaFi but usually not for very long and at kind of odd times. I never saw it "Offline" until a week or so ago when it was parked at a detailing shop having paint protection applied. Then I did see a couple of instances of offline. My takeaway is that the car needs to sit for some period greater than 24 hours before it will go offline, because I do drive the car daily and only saw these offline instances when the car had been parked for an extended period. 

Starting yesterday, my new MCU Model X started sleeping.  I haven't had a software update lately, it just randomly started ..

Mine is sleeping more than it used to as well, but very sporadically. I will see it sleep for an hour or so, then revert to "Parked" for a few hours, then sleep again and so forth. Not sure why the car keeps waking up like that. I don't think I've ever seen it report "Offline" in TeslaFi.

I just set TeslaFi up for my Model 3 today (also Intel MCU), and the car has not yet gone to sleep after 3+ hours idle.  kWh loss for this last idle period has been locked at 0.46 kWh for more than an hour, so perhaps on the 3 idle is the expected state?  It's unclear to me, as the only mention I've seen on the TeslaFi site is that sleep is automated on the 3.  


I'm on firmware 2018.18.3 if that matters.  

+1
Under review

Hi,

Some cars seem to be having issues on this version and other are sleeping fine so hopefully it's an intermittent issue that will be resolved on it's own or with the next firmware release.

In the meantime you can try enabling TeslaFi sleep mode under settings->sleep modes.  It should resolve it until things clear up on it's own.  Let me know if you need any help.

Thanks,

James

I enabled sleep and had to un-check the two temperature boxes as the Model 3 appears to continue reporting them indefinitely when polled. Once I did that, the car consistently goes to sleep after 11 of the 15 'try to sleep' minutes have passed.  Multiple other Model 3 owners on TMC have reported the same success, so this seems to be a consistent change on the 2018.18.x firmware releases.  


Here's a raw data feed example in case this helps you change the default behavior so this 'just works' on Model 3s without owners having to tweak Sleep settings.


One follow-up question--what is the risk of missing drives while TeslaFi is attempting to let the car go to sleep?  


For example, if I have the car set to 10 minutes idle before sleep, and 15 minutes  time to try sleeping, and the car routinely takes 11 of those 15 minutes to sleep.  Is the risk that I start driving during that 15-minute non-polling window and TeslaFi doesn't realize it until the 15 minutes are up, therefore missing whatever portion of my drive began during those minutes?  Or am I misunderstanding and the service would realize the car is driving even during that window?

+1

Right, if anything happens within those 15 minutes TeslaFi won't catch it.  If it only misses part of a drive TeslaFi will fill in the blanks and you most likely won't notice that it missed data aside from the map not showing a portion of the drive.


You can enter a mobile number to receive texts when the sleep session is starting and reply back if you're going to drive and start polling again.  Or you can receive an email and click the link to start polling again.

Hi

I have the same issue . I lost power saveing mode after resetting. Now 7 m drain. Can Teslafi help this?

+1

I can also confirm that my Model 3 stopped sleeping after installing 2018.18.13.  Enabling TeslaFi Sleep Mode with the default 15 min Time To Try Sleeping, 30 min Idle Time Before Trying To Sleep and unchecking both temp readings is working great so far!

+2

Model 3 on software 24.7 everything about TeslaFi "Sleep Modes" worked perfect! 


Since last week on 28.1 and now 28.5 there is consistent sleep and offline issues. Very frustrating. 


The only time my car will sleep consistently now is ONLY when plugged in/charging at home at night. Many reports of the same in the forums.


No other software running, rest the computer several times, no temp options selected as listed above... what else can I try

Glad it's not just me! Hope another update fixes this... I want it to aggressively sleep.

+1

What does "Reset Idle Timer When Offline" do?

I'm guessing it will continue to poll the car for info every minute (or whatever your timer is set to) even when it doesn't get a response from the car. I'm guessing this could potentially prevent the car from sleeping consistently in some rare instances.