Under review

Schedule Stop Charging Command Fails to Detect Car is Actually Charging

GQG 3 years ago updated by James 3 years ago 1

I've seen a problem several times where the vehicle is actively charging but the stop charging command returns the error "Not Sent: Vehicle is not charging".  I'm not sure if my deep sleep settings are correct or if something else is wrong.

I tested it by sitting in the car during the overnight sleep period and issuing schedule commands.  The Wake command worked; the Start Charging command worked; but the Stop Charging command failed with "Not Sent: Vehicle is not charging".  I noticed on the app a "Start Polling" button and pressed it.  Then the Stop Charging command worked.  Any idea what's wrong?

Under review

If deep sleep mode is on then TeslaFi is not polling the car for data.  If the vehicle was not charging before deep sleep mode started and then started charging while deep sleep mode was on then TeslaFi does know that it's charging and disregards the command since it thinks it's not charging.  You don't want to enable deep sleep mode while you'll be charging.