0
Fixed

merged drives disappear

velociped77 2 years ago updated by EDIflyer 4 months ago 8

when you merge a merged drive to another drive (press twice "merge"-button, all drives disappear and are not longer in the stats.

Fixed

Thank you.  The merging drives wasn't designed to merge a drive with another merged drive and then unmerging them.  I have put in a catch to prevent the merging of a drive with another merged drive.

I merged a drive 2 with another drive 3 this morning.  Then I tried to merge the second leg of my morning commute 4.  The last drive disappeared.


Sorry for the delay.  Somehow I wasn't notified of your reply.  Drive 4 should now show up again.

Hi, I just did a trip from Tauranga to Auckland but stopped for a coffee and a toilet break. I did a merge of the first part of the trip, then tried to do a merge for the second part and all of a sudden one of my trips has disappeared, i tried to un merge but still missing one of my trips. Please can you take a look

Thanks.  I believe I restored the drive and corrected the merge page to not show the merge button when there's no available drive to merge with.

Rather than potentially losing my trip again, is it safe to add the third leg of the trip into the merge, or is this still not a function of merge?

You still can't merge three drives together.  Only two drives can be merged together.

I'm receiving errors when trying to merge any drives:

"Fatal error: Call to a member function fetch_assoc() on boolean in /home/tesla/public_html/driveCalc.php on line 614"

Commenting disabled