+2
Fixed

Scheduled charge incorrectly failed to match location

mcwill 2 years ago updated by rarekind 2 years ago 6

I set up a scheduled charge to warm up the battery prior to a long trip but the scheduled task failed to send to vehicle because TeslaFi thought the vehicle location didn't match the selected value of "Home".

However the car was sleeping at home as logged by the system.




The only contributing factor I can think of is the drive/entry to Home was missed as TeslaFi was attempting to let the car sleep.

Hi,


The data logger relies on the location of the last completed drive.  Since your car was attempting the sleep it it missed the location.


I have a new version of the data logger which will check the current location before running the scheduled command plus a few other changes.


If anyone would like to run this new version before I release it please email me at support@teslafi.com with your username or car id.


Thanks,


James

My morning schedule has been failing to do Start HVAC. The location was set to ANY. I've changed the location to HOME (which actually makes more sense ... I won't be going to work at that hour if I'm not at home ...) and I will see if that makes a difference. Its been working fine in the evenings (for which the schedule-location was explicitly set to WORK)


Also: could the Log show the Date/Time when the action was performed? Looks like (green box) there was a retry, and when I scroll down knowing which week the days are is not obvious



Update: Actually it was working correctly last week (and now I think about it the car has been warm on departure). So worked OK up to last Friday, no schedule for Sat/Sun, did not work on Mon, Tue, Wed. No change to the schedule (until I changed it from "Any" location to "Home" this morning).

Fixed

A location check is now run within the data logger before executing a schedule to make sure the last known location matches up with the schedule.

I am experiencing this same issue. The car location is asleep and at home but the below schedule is not running. If I change schedule location to 'Any' it works as expected. Am I missing something here?

Commenting disabled