Iam not able to create a new token

sdt15749 7 years ago updated by James 7 years ago 3

I was informed by mail about expire of my token in 24 hours.

I have logged in to teslafi.com and tried to create a new token but i got following error message:


file_get_contents(https://owner-api.teslamotors.com/oauth/token): failed to open stream: HTTP request failed! HTTP/1.1 401 Unauthorized
A token could not be obtained from Tesla. If the above error shows a 401 Unauthorized Error it means you did not provide the correct Tesla.com credentials.


To double check my credentials i have logged in to mytelsa and have also tried to create a new token on teslalog.com - both works without any problem.

Due to this iam sure that my credentials are valid but iam not able to get a new token.

In addtion to this i have lost my existing token at telsafi.com and now iam not able to get any info from my car via teslafi.com

Please solve this problem or tell me how i can create a token by myself to add this manually to telsafi.com



I just added character encoding to the token form which should correct this if you want to try it again next time.




i have also tried several options to get it back working.

First i copied the token from Telsalog to TeslaFI but TeslaLog is not showing the full token info and so TeslaFI was not able to use this incomplete token info.

As next i checked my mytesla password and identifed that i have use a special "german" character "ö".

I have changed my tesla password to get one without special characters.

After some time i has tried again to request a token via TeslaFi with my new tesla password and when it work.

I assume the special character was the reason.

TeslaFi is now collecting data from my car - great

by the way - thanx a lot for TelsaFi - i really like it and get a lot of helpful information from TeslaFi.

Dankeschön from Germany <g> - problem solved

Under review

Hi. I just tried creating tokens on two different tesla.com accounts and it worked correctly.

I'm not sure what the issue is. I would try reseting your tesla.com password and try again. It doesn't make sense because teslalog.com works but it's worth a try.

I guess it's possible that a long complicated password or special characters could be causing an error when passed to the API but I haven't seen this after generating thousands of tokens.

Please let me know if changing your tesla.com password and generating a new token works.

Thank you,


Commenting disabled