0
Not a bug

Battery usage percentage sometimes is wrong

StefanSarzio 3 years ago updated by James 3 years ago 3

Today my last two drives are logged as:


1%, 0.93 kWh


2%, 0.92 kWh


I think it doesn't make sense that the first percentage is lower while the kWh are slightly higher.

Answer

Answer
Not a bug

The battery percentage is rounded to a whole number somehow and has an accuracy of .9%. The kWh is calculated through rated miles used which has an accuracy of .1 miles and a scale of 200-300 miles. Plus the kWh used is rounded.


For example:

89.9% - 91.1% could be reported by the API as 89% - 91%. 1.2% really used - 2% reported by the api.


89.6% - 90.9% could be reported by the API as 89% - 90%. 1.3% really used - 1% reported by the api.

Answer
Not a bug

The battery percentage is rounded to a whole number somehow and has an accuracy of .9%. The kWh is calculated through rated miles used which has an accuracy of .1 miles and a scale of 200-300 miles. Plus the kWh used is rounded.


For example:

89.9% - 91.1% could be reported by the API as 89% - 91%. 1.2% really used - 2% reported by the api.


89.6% - 90.9% could be reported by the API as 89% - 90%. 1.3% really used - 1% reported by the api.

How about now using Teslas battery percentage (which is heavily rounded as you state) but your own calculations based on the rated miles at 100% (individual car factor) and the rated miles used for this drive. Like you do for the kWh, if I got that correct.


This way the value would be more exact and would be in line with the kWh.

I converted this into a feature request. Thanks

Commenting disabled