Under review

weird sleep pattern: car will be woken up after ~5-50min of sleep

lewurm 5 years ago updated by Mrklaw 3 years ago 79

Since 12/12/2019 my car only goes into sleep for a quick nap. It almost never sleeps longer than 50min anymore, wakes up for apparently no reason, and then goes into sleep after 40-45min again. First I thought it would be connected with the 2019.40.2.1 update. I reset my Tesla password and generated a new token for TeslaFi, so I would be sure that no other third party app (and even Tesla's app) doesn't interfere. That sleep pattern still showed up, so I contacted Tesla because I thought the car wakes up for some reason on its own (as I stated above, I thought it was connected with the update). However "Tesla Virtual Service" confirmed that the wake up reasons are due to a third party app. Since TesalFi was the only application at this point with a valid token... it must be TeslaFi. It is a bit surprising to me because there isn't anything visible in the raw data feed (e.g. an intended wake up call). Is this a known issue?

Here an example from 12/27/2019

Image 1546

Here a screenshot for the according raw data feed

Image 1545

My sleep settings

Image 1544


2 weeks later, and the Model 3 is sleeping normally. Looks like this voltage controller to the drivers seat was the culprit.


Tesla SC replaced a voltage  controller for the left seat. It was periodically dropping voltage to the seat occupancy switch. This appears to solve the problem, car now going to sleep on its own. 

Previously replacing the switch and the entire seat suspecting the wire harness was not the solution.

advanced engineering was instrumental in resolving this. I had to provide them, through support, with a very exhaustive list of actions taken prior to this.

I have been at it for quite some time now and it seems troubleshooting was complicated by a faulty SD card in the MCU. For me as a user that basically made it impossible to get consistent behaviour. The SC replaced the SD card but were not able to reproduce my sleeping problem.

My issues were a little different from most of what I'm reading here as my problem is getting a lot worse if the car is connected to the charger. Specially at night with deep sleep activated I had 9 or 11mins of sleep each time before waking up.

That problem did not go away with the new SD card so I wend back at it. For me it seems the new beta feature to delay polling fixes my problem if set to 2 mins. However, I have been reading the comments for that setting so I was expecting to see a remark in de logger notes once triggered but nothing there.

So I set it back to 0. Problem resurfaces. (even says charging state: charging for one poll). Set delayed logging to 1, problem remains but the charging state says starting. So set it to 2 again and car is sleeping like a baby without waking up but also.... without any logger note stating delay logging is active !

I am going to leave it like this for a while and try various combinations of cable plugged in or disconnected. I'm driving a Sep2019 Model X Performance (Raven). 

Just came back from the garage which accidentally confirmed behaviour. The Tesla was indeed charging for a little while which now no longer shows in Teslafi due to the 2mins poll delay.

Please note that the Tesla has only been in there for 90mins or so. So it completed charging from 59% to 60% only 90 mins ago to apparently wake up and charge for under 2 mins and immediately report that it's sleeping.

I will call the SC again tomorrow and ask if this is expected behaviour because I have never noticed this before.

James, et.al., I'm going into SC tomorrow for them to "remove a HW issue preventing advanced engineering from resolving the issue remotely". I don't know exactly what this is, but that's current status with Tesla. I intend to stop logging for both my cars while they inspect. (to avoid the "some 3rd party" issue)

This delay change you made to the logging on the one hand, appears to be beneficial, however, on vacation at this same time, so car is staying home in the garage, and normally it's at work with Sentry on.

Since I restarting logging after the 5 day stop of logging on 10/1-10/5, I was only able to observe 3 "tiers" of sleep usage, see table below. When vacation started and coincidentally the logging delay change are consideration. I suspect adv engineering was inspecting the vehicle on 10/15 and they may have tweaked something as well, as sleep times did grow then

10/6-10/13 - 30-45 minutes per day

10/14-10/17 - 1-2 hrs per day, tesla email on 10/16, probable inspection 10/15

10/18-10/22 - 6-7 hrs per day - new logger setting, plus vacation at home

again, if other users have 2 cars with one sleeping the other not, I'd like to hear about it, additional information for engineering. In my case, the 1st one in the vehicle list is the car not sleeping properly.

My wife and I have 2 cars listed in each others accounts. To ensure this is not related I have removed them but that did not make a difference. As I posted earlier. I think I have found my culprit so I will continue monitoring this week before adding the cars to each others accounts again.

One thing worth noting; in the Netherlands it has not been very cold yet so using the app to preheat etc has not happened since I have this problem (June/July). This means we hardly use the Tesla app as she has a key fob for the M3DMLR and prefers that over using the app.

Looking at my car's sleep last night, it appears like at the beginning it was awake longer than later in the night. Eventually it seemed to stay asleep hours without waking up.

Of course this could be temperature related, but it might indicate that some kind of strategy where the polling delay is longer early in a sleep period and shorter later might help to avoid losing data after a legitimate waking.

Thanks James!

I had to set the time delay to 6. It's been through two of those time delays now without waking up. A whole 47 minutes of solid sleep. Delays of 2 and 4 didn't seem to work for me, but not a lot of experimentation yet. 

I think this solution makes a lot of sense given what I've seen in my logs. 

There may be a solution for this issue that another member found with some logging and help from a service center.

Basically what they found was that the MCU wakes up periodically and then immediately falls back to sleep within a few minutes.  The service center stated this was normal behavior for MCU1 -> MCU2 upgraded vehicles.

I have a beta version of the logger that incorporates a set time delay when the vehicle comes back online coming immediately from a 'asleep' or 'offline'.  So far the few vehicles it's being tested on do indeed fall back asleep within 1-2 minutes and eliminates this short sleep cycle.

If anyone would like to try this out please let me know.

I already put tgposz and DMX2017 on the new version and the time to wait until polling for data can be set in settings->sleep mode->advanced.

I've got this issue now, just upgraded from MCU1 to MCU2 yesterday. 


This has been put in place for all accounts.  It can be enabled in settings->sleep mode->advanced.

James, this may be useful for Teslafi usage, but my basic issue is being idle all night long and using 7-10% battery WITHOUT teslafi. I am trying to get Tesla to work this issue. Right now, I will try using this, because I want the value add that teslafi brings. To help them diagnose what's going on, I will remove Teslafi at some point.

I'd be interested in trying this too. My Model X is also not upgraded from MCU1 to MCU2 (it started on MCU2), but I did get the HW2.5 to HW3 upgrade, for what that's worth. It usually only sleeps 15 minutes or so before waking up.


Hi James, could you please apply this to my Model X as well?  I wasn't on MC1-->MC2 upgrade path, but I do have an MC2 and been experiencing this for months now.  

@James, curious if you added my Model X to this solution?  Sleeping for almost three hours now which is a good sign ;)

I disabled everything for 4 days, the 2nd car in my acct slept fine, the first and original did not. I have provided timestamps to Tesla for them to pull logs. I have suspected, in the Teslafi case, they see any 3rd party API use, including the vehicle list API call, which doesn't go to either vehicle, and they just give up. I haven't had any luck in taking to engineering directly, it's already through a support rep or the service tech.

does anyone know if the Tesla app itself uses these same 3rd party API calls?

I have never had STATS. I have signed into ABetterRoutePlanner for live updates from the car, so that may be a possibility for me. I thought changing the Tesla account password would fix any problems with apps doing status checks. Not that I've done that yet.

I'm on Android.

I did enable TeslaFi Deep Sleep, without status checking, and the car seemed to sleep OK. Only 0.5 mi or so of range drain in a 24 hour period. I usually lose 5-6 miles without Sentry. Before this problem, a drain of about 1 mi/day was normal.

I installed 2020.40.3 yesterday. Disabled Deep Sleep and it was back to 15 minutes of sleep and 1hr 12min of Idle. So no fix with a firmware update yet.


My car has been having sleep pattern issues lately as well and I was able to find out that it was STATS app that potentially interferes with TeslaFi that is constantly waking up the car after TeslaFi puts the car into sleep. STATS response was that two different 3rd party apps may not work well with each other and causing the vehicle to have weird sleep patterns from time time. I love using both apps so would love a solution if anyone knows...STATS would not go into details explaining their vehicle polling strategy so I am hoping to tweak TeslaFi settings to help.

I have reinstalled STATS this morning and will report back on what I find out. Seems like may software bugs after IOS14 updates...

I can confirm now that it was indeed the STATS app that was causing the issue. Not working well with TeslaFi I guess and there is no way of changing or knowing how frequent it wakes the car up for updates. My main purpose in using STATS is its Apple Watch functionality and I have since started using "Watch App For Tesla". It has worked flawlessly. 

My 2017 Model X sleeps roughly 10 minutes at a time. I can very that a bit by changing the sleep settings.

From my TeslaFi logs, the problem started 7/24/2020. That was a few days after HW3/MCU2 upgrades and the same day I installed 2020.24.6.9 firmware. I'm on 2020.36.11 now and still have the problem.

We do have two Teslas (the other is a Model 3 that sleeps fine) in the same Tesla account, with linked but separate accounts on TeslaFi. 

I haven't tried changing the Tesla password, just for the hassle.

We were on a road trip and were parked at our destinations overnight with Sentry off. Still had the same short sleep pattern.

how many of you having this problem have 2 Tesla's?

i have been thinking, maybe this is a 2 car on the account problem. The first API call for the list of cars, Tesla is counting that call as a 3rd party app call even though it's ultimately to gather data on my other car... And then they just quit looking.

even after changing out the entire seat, car is still not sleeping. They continue to claim that a 3rd party app is polling repeatedly, but for this car, I have logging off. Password had been changed again, to no effect. How can a token still be valid to allow something like this to persist. Tesla claims they cannot "sniff" which IP addresses traffic is coming from. Only that it's a 3rd party app. Of course, changed password again, no change.

Been reading all replies and I have the same problem on my MXPR. The difference (I think!) is that I do not experience it when the car is not plugged in. Haven't had the time to try and eliminate yet as I figured Teslafi had something to do with it so mostly tried changing sleep settings.

Will disable polling and validate if it happens without Teslafi as well. Any suggestion on doing that without the app ? Cigarette lighter with a led installed or something simple ?

Read other posts as well and disabled all new location based gadgets like locking the car except when at home, ensured a stable wifi connection, disable wifi, leaving the car locked or not etc etc... 

James, can you put my M3 onto a separate logger that just does the vehicle list API. We have to prove to Tesla that the list API calls are not coming to the car.


last week mobile ranger changed out computer but sleep/idle pattern and this higher consumption because vehicle never stays sleep continues.

opened another ticket, service this week, and now convincing another tech person that teslafi is not necessarily the problem, so teslafi currently not logging and they supposedly are getting logs.

observation: the techs at tesla are all indoctrinated that 3rd party apps are all bad... Like a religion, having world view all screwed up doesn't help with investigation.

Tesla's SC changed driver occupancy sensor in the seat (if driver, then don't go to sleep) but the behavior continues. Have opened yet another ticket 

Thanks for the update.  Please do keep us posted on what they find in the logs from the vehicle.  I am seeing the exact same behavior on my MX MCU2 car as well.

Tesla checked more logs and had now determined that I have bad Ethernet port, forces vehicle to idle after handling the error when it first falls asleep. so computer to be replaced on 8/12. Others might have Tesla check on this error. Well let you know what happens.

I can try, but have

  1. removed wifi AP settings from car, 
  2. removed user/psw from Tesla app (have no key fob) 
    1. have also tried turning off bluetooth, but figured user/psw is more certain

what other things are there?

I car has the same issue with interruptions to sleep I have Teslafi set to deep sleep so no polling between MN and 5 or 6 but after that it doesn’t sleep despite attempts SW 2020.24.6.4

there may be two things going on, just a theory

1. the car, for whatever reason, at some periods is not going to sleep - Teslafi allowing it to go to sleep via deepsleep or regular 30 min wait to sleep is immaterial. 

2. Teslafi's use of vehicle API to check status (sleep, driving, idle, charging, etc.) is not the same any more as this API request is coming to the vehicle and waking it up. I believe I've confirmed this behavior on 2020.24.6.4 with the mobile ranger hooked up to the car, setting teslafi allow sleep now, teslafi waits the 15 minutes and does a vehicle status check, he saw this API request coming to the car.

Checking the vehicle list is this call:  https://www.teslafi.com/getData.php

It lists the vehicle state of either online, asleep or offline and does not connect to the vehicle. When the vehicle state changes it updates the state in this call.  When the vehicle is sleeping you can check this as often as you want and it will not wake the vehicle.  There are thousands of vehicles on TeslaFi sleeping with the latest firmware versions and still checking this call every minute to see if the vehicle has woken up.

Checking the vehicle data is this call:  https://www.teslafi.com/getData.php?type=Data

Calling the data call obtains all of the data from the vehicle and connects to the vehicle keeping it awake or waking it up if it's sleeping.  

During a sleep attempt only the vehicle list is checked and if you select do not check vehicle state then nothing is checked during the sleep attempt, essentially turning TeslaFi off during the sleep attempt time.

thanks James. I have put another call into mobile tesla for a ranger to come and validate the cars data from their viewpoint. Wish I had this before, could have done an explicit test with him there. Regardless, It's next week before they can get here.

I really would try to let the vehicle sleep somewhere outside of your home location.  There have been so many times things like this end up being an issue with weak wifi, weak cellular, a key fob too close, a cell phone too close and others.  I know it's not convenient but it can definitely eliminate many factors.


I've been noticing this pattern since my upgrade from 2020.20.12 to 2020.20.17

Mobile ranger confirmed that the "vehicle" API call is coming to my car and waking it up. At least some 3rd party API call is coming every minute. When I turned TeslaFi logging off yesterday, to see if it would sleep without any 3rd party, then the every minute queries stopped.

Since 2020.24.6.1 at end of June I'm having the described issue of only sleeping for 1 minute and then waking. Telsa mobile says the logs are showing a 3rd party app (Teslafi is only one) coming in via the API to wake the car. Presumably the "vehicle" api call is now going to the car and waking, when before would only use the Telsa servers to check vehicle state (asleep/idle/offline/etc.). 20202.24.6.4 has same behavior.

I'm on 2020.24.6.4 and I can't confirm this behavior.

I recommend changing your Tesla password (thus all tokens will be invalidated) to rule out any other 3rd party app. Next would be to check your sleep settings on TeslaFi.


yes, I've done that a couple of times to rule out other apps, even to confirm that teslafi logging is off, to Tesla's satisfaction.

I'm seeing the same thing (at least in general) with 2020.12 and 2020.12.1- teslafi doesn't report it staying asleep much of the time and it'll wake up on its own. The car is in a garage, no 3rd party access other than teslafi, no sentry mode, no preconditioning. Because of the virus issue, I've not driven it in a few weeks. It'll stay sleep for a day or two, then it'll spend 10-15 hours in an idle state for a day or two before going back to sleep. Really annoying as I'm losing ~1% of charge per day, which is 2x more than I was losing when it was 20F cooler (40s for the high vs. 60s).

Good to know I don't have to look further. I have a very similar problem with 2020.4.2. Bluetooth on mobiles deactivated, only teslafi active. It is going to sleep, but after a while it will just wake up again. Strangely, I get API errors just afterwards with timeouts, that might actually be a teslafi bug?


I don't use TeslaFi and have the same issue. Car is going to sleep after 10 minutes and after another 10 minutes it wakes up again. Is in service center since about 5 weeks, they can't figure out the reason... I realized the issue, would say mid December, but no idea how long the issue was there before...


Update: I finally got a Tesla service appointment (not their fault it took so long, I had to reschedule it a couple times). Luckily I got to talk to a technician and after thoroughly explaining the issue he had a look at the car logs. Additionally I was able to tell him a 10min windows where a wake-up happened. The way I did it: (1) I installed a OBD connector to the Vehicle CAN behind the center console. The idea is: The provided 12V connection goes down when the car sleeps, so I can't connect via bluetooth to it. (2) I invalidated all my tokens, uninstalled the Tesla App on all devices (to avoid wakeups via bluetooth key). and (3) I had a look every 10min if I can connect to the OBD connector. And indeed, after going to sleep pretty quickly, the car woke up again after ~40-50min.

Given with the timestamp the technician was able to extract the wakeup reason. With that he found an internal "article" that describes a problem with the HV battery firmware. Under some conditions related to cell voltage fluctuation the HV battery firmware can send a wakeup to the MCU. Proposed solution: (1) Try decharging close to 0% and fully charge afterwards, or (2) wait for future software update (Note: 2020.8.1 still has this problem).

TL;DR: It's not a TeslaFi issue, but a firmware bug in the HV battery software.

I've updated from 2020.16.2.1 e99c70ff to 2020.20.12 d2c8a3e11 today, and my car is sleeping properly again. FINALLY, after almost half a year this issue has been fixed. woot :-)

So, it was just the update that fixed it -- not anything you did, and not anything that Tesla service did?

I had the same problem 4 months ago, and just gave up on TeslaFi after Tesla repeatedly blamed third party apps. I just decided to sign back up again and hopefully won't see the problem -- but want to prepare in case I do.

Yep, nothing but the update.

Thank you very much for this information. In my country they are just telling me, it's completely normal and don't even bother to investigate. So we have to wait for future updates...

ok, so after disabling the cabin overheat protection, my car has been sleeping for 1h 50min, so this fixed it. 

after upgrading to 2020.8.1 I have this sleep/wake pattern now, car goes to sleep then wakes up on its own after exactly 1 hour. I do have cabin overheat protection enabled. I will disable it and will update. 

no idea if this is related but I saw similar types of patterns when I had cabin overheat protection on, even during cold weather.  It would wake up periodically to check the temperature I guess, and then as you'd expect teslafi would magnify the awake time. 


Starting from Feb 4th I no longer see the weird sleep pattern and my car now sleeps for much longer duration. I received 2020.4.1 on Jan 30th.

Thanks for the update, that's interesting! Can you think of anything you have changed?

Upvoting this because my Model 3 shows the same behavior since when I got it 3 weeks ago: sleeping for 1 minute and awake for 41 minutes - nothing is activated (no sentry, temperature control, wifi, ....).

I'm on 2020.4.1 since the weekend but no changes at all, so I installed TeslaFi yesterday to see what's happening but don't get an idea, why the car doesn't go to sleep 'normally' or as expected.

Thankful for any help!

I get exactly this pattern with default teslafi settings - 40/41 minutes of park, followed by 1 minute of sleep then instantly back to idle. I only have teslafi third party app connected (plus tesla app), have everything turned off like sentry, cabin overheat etc. Just picked my car up but noticed it was losing a few % overnight which prompted me to install teslafi 

Is it always sleeping only for 1min? If yes, I would speculate it's a different issue as discussed here.

Are you sure you don't use any other 3rd party app? Try a Tesla password reset to invalidate all your tokens and only login into TeslaFi and see if the behaviour remains.

If yes, what are your Sleep Mode settings on TeslaFi?

Its a brand new car - picked up on Wednesday last week (so 5 days old). I’ve only signed in with teslafi so no other app could be using it with my credentials. I was using the default settings - earlier today I went for a short drive to make sure it was awake, and adusted the ‘time to try sleeping’ from 15 to 25 minutes, and checked the ‘do not check the vehicle state’ box (both suggsted by teslafi as troubleshooting options) 

It then changed responses, increasing the Parking length from 41 to an hour, and more recently looks like its sleeping - but this was around 3 hours after changing the teslafi setting. I’ll check again in the morning - not sure why this changed behaviour? or is it just not checking if its still sleeping so I won’t really know? 

I’ve also turned wifi off but seems that’ll go back on when I next get in the car? I’m right on the edge of my wifi so it can’t really connect to my home wifi which is frustrating as its a good router. But I removed my network so there are no saved wifi networks in the car

Under review

I've taken a look at the vehicles that are experiencing this but I cannot determine any issue on TeslaFi's side.  While the vehicle is sleeping, only the vehicle state is checked which has never woken up the vehicle. Enabling sleep settings to limit vampire loss.  Nothing has changed on that side within TeslaFi so I'm not sure where else to go from here.

Many times in the past, sleep issues pop up with certain software versions and are resolved within the next few software updates so hopefully this will too.  The only change that could be made on TeslaFi's side is to stop polling the vehicle state when the vehicle is asleep but TeslaFi would not know when the vehicle wakes up and would miss large amounts of data if some sort of timer was added to periodically check to see if the vehicle was awake.  I've also had a few reports that even after turning TeslaFi logging off the sleep/wake cycle continues so most likely this would not achieve anything.

Thank you James for taking the time to look into it.

At this point I'm pretty certain it's a problem in the firmware. I disabled TeslaFi and periodically checked the car state via the iOS widget.

2020-01-07, 09.39pm CET: last app access
2020-01-07, 09.41pm CET: checked via iOS widget, still awake

2020-01-07, 09.54pm CET: checked via iOS widget, shows as “Asleep. Updated 13 minutes ago”.
2020-01-07, 10.05pm CET: checked via iOS widget, shows as “Asleep. Updated 23 minutes ago”.

2020-01-07, 10.13pm CET: checked via iOS widget, shows as “Asleep. Updated 32 minutes ago”.
2020-01-07, 10.20pm CET: checked via iOS widget, shows as “Asleep. Updated 39 minutes ago”.
2020-01-07, 10.27pm CET: checked via iOS widget, shows as “Asleep. Updated 45 minutes ago”.

2020-01-07, 10.34pm CET: checked via iOS widget, shows as AWAKE.

I contacted Tesla Service again, let's see what they have to say.

I tried one more thing: A "hard reset" described as here: https://www.mountainpassperformance.com/tesla-model-3-hard-reset/

That is, disconnecting the HV and 12V battery. Still I have the same behavior :(

While at it, I left them disconnected for ~15h and checked on the voltage of the 12V battery. It dropped from 13.6V to 13.1V after said 15 hours which I think is still in an okay condition, and shouldn't wake up the car for 12V battery recharging.


I have a very similar problem. Car wakes every 10 minutes (exactly) after it goes to sleep. This started after 2019.40.2.1. Phantom drain increased about 4 to 5 times. Losing now 25 - 30km per 24 hours. Called Tesla support: They said Teslafi is at fault.

So I did a bit of testing: changed password, disabled Teslafi, parked my car in a garage without any connectivity. I waited 1 and half hour by my car to check. It goes to sleep and wakes up exactly after 10 min, then 2min idle then 10min sleep and so on it goes. I have to call tesla again, maybe they can check the logfiles remotely...

had you any success contacting Tesla about this issue?


I did have success contacting Tesla. But they are telling me "It's normal to loose up to 10% per day", "It's an electric vehicle after all". Yes I am deeply disappointed by Tesla. I can have a diagnosis, but I have to pay it and It costs roughly 210 dollars per hour...

I checked my logs and the problem started on Dec 19 after 5pm EST because the previous night the car went into sleep like how it normally does and was asleep for the most part of the night until I drove to work on the 19th morning.I had 2019.40.2.1 installed at that point. 

Are you all on 2019.40.50 with text messaging Bluetooth enabled and your phone nearby? Only way I got this to stop was disable message sync on the car. I thought more recent versions (40.50.7) had fixed it but not so. 

I disabled bluetooth on all phones, but seeing still the same behavior.

I'm on 2019.40.50.7 and have this issue. I turned off Bluetooth on my phone to see if that helps. If not, I will try to turn off message sync like you suggested.

FYI I did a factory reset on my car. The problem is still there.


Yesterday I activated Nighttime TeslaFi Sleep Mode:

And the behavior changes slightly (which I think is expected):


Upvoting this as I see the same issue with my Model 3. I can post screenshots later tonight or tomorrow.


EDIT: After a second thought I think the picture below doesn't proof anything. The iOS widget doesn't constantly check the state of the car, so it would miss short wakeup periods of the car.

I did another roundtrip of resetting the Tesla password, but this time only enabling the Tesla App itself. If the iOS widget is trustworthy, the car goes properly into sleep without TeslaFi being enabled. Another evidence that it is likely a problem with TeslaFi.


Since a week or so I have noticed a very weird sleep behavior as well. My car seems to sleep for 1 minute many times a day. It also does a 'real' sleep now and then, but then this weird 1 minute pattern repeats itself again.

I have been using Teslafi for almost a year now and never had issues with sleeping. Well, I always have found the behavior strange: Around 7 hours of sleep, then around 3 hours idle, and this in repeat.

During last week (after the 1 minute sleeps started to appear) I got a firmware update (2020.36.3.1) but it did not change.

I did change my Tesla password to disconnect any other tool that might be connected (which would be weird since I don't use any other tool, but still).

Car: S90D 2016 AP1 MCU1.

In the raw data feed the data also is a bit strange:

From trying to sleep to vehicle dit not fall asleep to sleeping to idle.. 

The times my car actually falls asleep it usually takes around 10 minutes.

Anyone got a clue what could cause this?

I changed my password again and only reconnected Teslafi. Not even the Tesla app. I forced Teslafi night sleep mode by setting it from 8:00 to 7:00. The behavior didn't change. My conclusion is that it is something in the car that is causing it but I wouldn't know what. 

Hi. Same for me, I have a TMS 2014 AP1 MCU1, with 2020.36.11. my car does not sleep, only "1 minute" at a time, the reality is that it does not sleep. However, I've seen lately that my steering wheel computer is sleeping (must wait until it is started up when I enter the car in  the morning), but the main display is not. 

I thought it was a problem after a service appointment in july - after that the car changed the sleeping habits to 1 hour sleep sharp - then always a wake-up, and then various non-sleeping time. 

After a major breakdown on my car and an additional service time period (10+ days at Tesla's garage) it has only slept 1 minute.

I'm waiting for the next software release being pushed to AP1 cars. Hoping it soon appears, and that this will resolve the sleeping issue.


Hello Björn,

i have the same model as you TS 2016 AP1 MCU1 with 2020.36 software and have since 2 month same problem with sleeping mode.

My Tesla awakes exact every 60 minutes, start the fans for 15 seconds to cooling (what?) and after that switched off.

i changed the password in Tesla account, all phones with Tesla app are switched off, no WLAN.

but the problem is still here.

did you find any solution in your case?

No luck. New firmware on my car also, made no improvement. At the moment, I've given up.

I observed the same thing. Mine is a 2021 model 3 LR AWD. It starts the fan for 15 min and then go to sleep for around 45 min making it a 1-hour cycle for most of the night. Is this caused by the car firmware or a 3rd party? I have teslafi and stats for tesla and of course tesla app. Anyone else found the solution?