Car not sleeping since 2019.24.4 73fb1ab installed on 25/07/2019 9:40 AM

twyningtesla 5 years ago updated by anonymous 5 years ago 41

I have been a TeslaFi user for almost 2 years and rarely had any issues.  I do not believe that this issue is related to TeslaFi, but want to see if any other users are experiencing it.

Since installing the above update, the car will not sleep.  I've tried extending the length of the "try to sleep" window, and even disabling polling for a day, but the car remains awake always.

Sentry mode is not enabled, Always Connected is set to OFF and Energy Saving is set to ON.

Anyone else experiencing this?


It's been resolved. It's the new "Summon" feature. Turning it off solves the battery drain (apparently at home summon isn't in "standby" mode and that's why no batter drain at home).

Glad you got it sorted!! We don't have the new Summon in the UK so only needed to do the reboot. 

started to have the same problem after the big V10 update...can't go to sleep even with time to try set at 30 min.

I had the same issue until I did a full reset (ie pressing brake pedal too). Since then it was fine. Then the small extra .1 update came out and it went to idling all the time. I repeated the full reset and its been sleeping for days now (I'm on holiday) with only the usual 3h or so of idling each day that I presume is for normal housekeeping. 

thanks. Mine still has the problem after full reset (and two more minor updates). Looks like might be connectivity related (sleep fine at home but can't sleep at train station with wifi turned off)

Ah OK, shame. I just installed latest update and had to do reset again but has been sleeping since. Interesting re connectivity potentially being an issue. 

For what it's worth, it appears that Tesla changed a few things since 24.4 and doesn't stop reporting temperatures before the car goes to sleep. As such, if you have those options checked in "Try to Sleep requirements", Teslafi won't stop polling and the car won't go to sleep. Tesla DOES however stops reporting the shift state, so you should enable that option. So, for me, with a pre-April 2018 MCU 1 Model S on 28.3.1, unchecking both temperature reading checks and checking shift state reading allows the car to sleep again in an optimum manner. 

Same here. Very frustrating. I read the instructions carefully and played with the settings. unfortunately the car will not sleep. The only way what helps is switch off logging and check my wifi router that the car is disconnected from the network. After that I enable logging. 

Since 2019.28.3.1 which I installed on 22/Aug. sleep mode works again as before 24.4. I did do a reset though.Even the temperatures are not transfered after a short time. Its taking just 10 minutes to sleep mode even with cabin overheat protection back on again, but with Requirement Outside Tempreading on again.

Experienced the same issue starting on 8/8/2019.   Model S Ap2 P100D w/ 2019.28.2.  I'm updated firmware to 23.3, and 28.3.1.  No change.  Just did the Time to 20min fix.  Will report back to see if it fixes the issue.  No configuration changes in TeslaFi in months.

why no response from Teslafi? 

Also no response to my ticket.

I've noticed the issue is related to the Tesla app. I've changed times in sleep settings, turned off Bluetooth on phone. Occasionally it will go to sleep if I refresh the app. But if I reboot my phone, killing the app connection, the car will sleep on default settings. Probably because it needs to be more aggressive to keep the wake delay down while causing sleep not to happen. 

I'm often getting Offline instead of sleeping status lately. I've in the last couple days I also had the car go "Offline" while driving. As soon as put into gear per data yet all the car connectivity items worked. Didn't come back until I got home. Something is really screwy with the MCUs lately.

I have had the offline problem too. Especially for the drive after sleeping.

Since then I wake up the car some minutes before driving the problem is gone.

Best wishes


I opened a ticket regarding this issue, but so far support has neither responded to this thread nor to tickets. Frustrating customer experience.

Did you change the settings as we did?

Do you have still problems with sleep mode?

Because my car Model S75 AP 2.0 June 2017 works fine now.

Best wishes



Changed the settings and it worked on 24.4 but no longer with 28.2

I changed the timeout to 20 and that seems to work (AP2.5, MCU 1 Model X), but I'm getting a 'didn't sleep' email then a 'did sleep' email about 1 minute apart.

Seems like there's an email timer somewhere that isn't reset.  Any ideas?

My car is sleeping only at home. Can't find any setting to change to allow it sleep everywhere? 

Thank you for the tip. I just increased the time to 20 minutes and now the car is sleeping :-)

Can confirm that for me the 20 minute "Time to Try Sleeping" setting works: my car is sleeping after 50 minutes of idle time (conform 30 minutes of "Idle Time" + 20 minutes "Time to Try" in settings) like a little baby :-)

Ernie hasn’t slept since the update. I’ll try the 20 min increase as suggested above.

  - Is there a way to force logging to restart before a drive, for example getting Teslafi to turn the HVAC on?

  - Any comments from Teslafi yet? Do they see this as a Teslafi problem and if so looking to advise on a solution for users?

UPDATE: 20 min sleep time has worked for me too. Many thanks to those above that found a fix. 


Solution for me was:

1. Uncheck all three checkboxes under "Try to sleep requirements".
Reason: Since 24.4, the car continously reports the temperatures. So missing temperature values are no longer signs that the systems are ready to sleep.

2. Increase the value for "Time To Try Sleeping" to minimum 20 minutes (was: 15 minutes).

Reason: It seems that now the MCU takes more than 15 minutes with no api polling to go to sleep.


Increasing the time to 20min seems to work for me as well, but it also increases the number of drives that are not logged (for example my drive to work this moring).

Thanks.  Will try this.  I already had all the 'Try to sleep' requirements unticked but had the sleep time at 15 minutes.  Have set it to 30 minutes and will see if this improves things.

Good luck. But too big values for "time to try sleeping" might result in data loss, for example when you start to drive or to charge in that period of time when Teslafi isn't polling.

Yes I know.

I have also turned on the notification emails so if the car is in a sleep attempt when I want to use it I will know and can easily resume polling. 


My car (MS 75D March 2018 MCU1 AP2.5) hasn't slept since Saturday when I upgraded to 2019.24.4. Have just have stopped the polling from TeslaFi, will let you know tomorrow if that made a difference. Battery loss ca. 2% in 12 hours.
Car settings: Sentry Mode off, allways connected off, energy saving on. Tried a reboot this morning, but car refuses to go to sleep.

TeslaFi Try to Sleep Settings: Time to try Sleeping: 15 mins; Idle Time before trying to Sleep: 30 mins; Reset Idle Timer when offline: checked; Try to Sleep Requirements: all unchecked.

So after 10 hours at night with TeslaFi polling off, I can report my car has been sleeping with no noticable range loss in 10 hours. IMHO this confirms that it is TeslaFi that prevents the car from going to sleep.

Will now try @Guillaume 's suggestion and have set Time to Try Sleeping to 20 minutes.

How do you confirm that the car went to sleep without TeslaFi? Just curious -

I turned off polling for a couple of hours today and the car did subsequently sleep.


i've got the same issue, disabling Teslafi polling allows the car to go to sleep. 

I'm surprised this isn't happening to everyone on 24.4 and using Teslafi, is there not a report Teslafi can do across the whole dataset to check if cars are sleeping or not now?


Ive found the last few updates where it fails to sleep or 30 minutes passes and it is "offline" but the car is sleeping 


Same here - no settings in teslafi changed but car no longer sleeps.


same here on MCU 1 model S, car slept once since the update (according to Teslafi), and I am losing about 20km of range a day from just idling.

For reference, my "Try To Sleep Requirements" have always been unchecked.


same here with version 2019.24.4 on both model 3 and S


Exacly the same here like Granada.
P85D with 24.4 from August 2015 with MCU1 and AP1.


Same here! Model S 70D from May 2015 with MCU1 and AP1.

Last friday I tried to reset the car twice and even tried to turn it completely off. This had helped for one night, but after using the car on saturday it won't go to sleep at all again and it's losing a lot of range every day.


I've been having issues as well. What did help in my case was to disable the Try To Sleep Requirements.
No Outside Temperature Reading:
No Inside Temperature Reading:

I've had my vehicle go to sleep a few times with these turned off. I noticed that in this new version (24.4) the car never stopped reporting the temperatures. This is a Model S85 with AP1


Yes, same here. Also started with 24.4. If I switch logging off from Teslafi the car will go to sleep. If logging is on the car will not sleep anymore at all. Have been using Teslafi since 2+ years and never encountered any issue with sleep mode before.

Edit: This happens on a Model S with MCU1 and AP2