+6

Clicking noises for 34 minutes after each ride, caused by TeslaFi requests during "idle time". Sleeping works fine.

TMS2016 3 months ago updated 2 months ago 7

After each ride TeslaFi wakes the car repeatedly for 34 minutes. After this the car sleeps as expected (until next ride or until the car wakes up on its own to recharge the 12V battery).

However during these 34 minutes the high voltage relay clicks every 60s (so high voltage is enabled for 1 minute, then disabled for 1 minute).

TeslaFi setting "Idle Time Before Trying to Sleep" has direct influence on the total clicking duration. If set to 30 minutes -> 34 minutes clicking, if set to 10 minutes -> 14 minutes clicking, if set to 5 minutes -> 10min clicking.

If TeslaFi is disabled (by unchecking "Logging Enabled"), high voltage is disabled only once (2 minutes after locking the car) and not reenabled (for hours). Then only 2 clicks of the shutdown sequence are audible.

"Polling Time While Idle" was usually set to 1 minute (default). If set to e.g. 5 minutes: the car enables the HV only for 1 minute every 5 minutes (for ~30 minutes in total, after a ride only). There is one loud click which indicates HV enabling. 60s later and 120s later two quiet click indicates HV disabling.

Test conditions

  • TeslaFi default settings restored by "Reset Settings"
    • Tesla Model S 2016 facelift, AP1, no sentry
    • 'Always Connected' is turned off
    • 'Energy Savings' is turned on in the vehicle.
    • 'Cabin Overheat Protection' off
    • No camping mode or dog mode enabled.
    • 'Passive Entry' off (so key fob does not wake up the car unintentionally).
    • No OBD connected
  • Tesla app was stopped sometimes, but usually just closed (because no effect).
  • No charger connected
  • Usually good LTE connection
  • 12V-battery voltage monitor (shows me e.g.: if the car is running from 12V battery or high voltage battery).
  • All available software updates installed.
  • Systematic TeslaFi tests performed on 2021-07-22 and 2021-07-23

I observed same clicking for ~30minutes on a Tesla Model S 2018 which also uses TeslaFi. The repeated clicking also disappeared after TeslaFi was disabled (by unchecking "Logging Enabled").

  • Same settings (additionally: sentry disabled).
  • No charger connected.
  • No 12V-battery voltage monitor
  • No OBD connected
  • All software updates installed.

I probably heard this clicking for more than a month on both cars (without observing it for longer time).

I tried modifying a few settings according to TeslaFi sleeping guide. Without success.

Is TeslaFi aware of that problem? It is not "Car is not sleeping".

Could TeslaFi poll faster than every 60s during idle time?

No feedback from TeslaFi yet.

However, for at least 4 days my Model S 2016 behaves well with TeslaFi: after a ride the high voltage is permanently ON for the duration of "idle time" and disables shortly after that, without unnecessary reactivation.


The Model S 2018 is still clicking. On closer look it does not enable the high voltage strictly periodic (usually every 2nd minute, but shortly after a ride the high voltage stays ON for 10minutes)


In both cases: Nothing changed since the initial test. Default TeslaFi settings. No charger connected. No software updates since the initial test.

Any feedback from Teslafi to this behaviour?

Not that I’ve seen yet. I’ve actually booked my car in with service for some other issues and asked them to investigate this too. 

+2

The clicks have been driving me mad for the last few months, I was about to book a service appointment but thought I’d better check it’s not Teslafi causing it…and it seems it is?

Here’s a boring video where you can hear the clicks, first one near the start and then jump to 60s later. 
I’ll try with TeslaFi disables tonight and see if that stops it. Only seems to happen when plugged in but not charging (ie set to charge 1230 to 0430). Only switched to octopus Go a few weeks ago so before that if it’s been plugged in and charging I’ve not had the clicking. If it does turn out to be teslafi polling has anybody figured out settings to get it to stop? Schedule rule to force sleep between certain hours, is that possible?

The timing is the same on the model S. Could you temporarily deactivate TeslaFi to verify that it's the same problem? (disable checkbox in Settings->Account->LoggingEnabled). Does it also occur after a ride, without being plugged in?

+1

Hi there,


I got the same problem, car is clicking everything 2-10 minutes at home, on the road when parked, only time it does not click is when it's charging.

This started about three months ago...

Once I turned "always online" off, clicking is reduced to a minimum but not altogether.

Is Teslafi aware of this out even had a solution?

My car: Model S 2017 75D

Cheers from Germany

Ben

+1

This is something I’m keen to follow as there must be a configuration of sleep settings to minimise the clicking to save wear and tear on the contactors. Currently I have disabled logging for the past 2 months