Tesla v3 API Tokens

James 3 years ago updated by hiroshiy 2 years ago 12

In October 2020, Tesla upgraded their API used to interact and obtain data from vehicles to a new system with two factor authentication as an option for vehicle owners.  This resulted in a new authentication flow used to obtain a new v3 token which TeslaFi implemented on December 2, 2020.  All new tokens generated within TeslaFi after that date have a v3 token.

Tokens generated before Dec 2nd were generated using the v2 authentication flow and as of January 29, 2021, Tesla is no longer allowing the v2 tokens to be refreshed when they expire.  

A notification will now appear on top of TeslaFi.com if you are using a v2 token indicating how long until it expires.  The version can also be verified by visiting Settings->Tesla Account where it will display v2 or v3 at the top of the page.  Emails will also be sent if you are using a v2 token and the expiration date is approaching.  It is recommended to generate a new v3 token as soon as you can to avoid any lapse in data logging should the v2 token expire and we are unable to refresh it.

Once a v3 token is obtained, TeslaFi will be able to refresh your token when it expires and no further action with the API Tokens will be needed.

You can generate a new v3 token at Settings->Tesla Account->Generate My Token.

Please feel free to open a support ticket if you need any assistance or have any questions.

Thank you,


**Edit Feb 4th 2021**

Tesla has allowed refreshing of v2 tokens again.  Any v2 tokens expiring will be refreshed but it highly recommended to obtain a v3 token as soon as possible.  It is unknown when v2 tokens will not be able to be refreshed again.

Not sure I should add to this topic, but I noticed after changing the Tesla.com password, I can't generate the token anymore. TeslaFi shows a temporary error, with the error code 6. i have tried generating the token several times but in vain.


Tesla added a captcha to their login process which has broken the authentication flow for TeslaFi to generate a new token.  We’re working on a solution now and should hopefully have something later today or by the end of the weekend.

If you have an iPhone or new Mac with the M1 processor you can generate a token using this app in the meantime:  https://apps.apple.com/us/app/auth-app-for-tesla/id1552058613


The new captcha form is in place when generating a token.

Thanks, James, that's what I guessed. First time to see the CAPTCHA on the sign-in screen. I don't have iOS devices, so I borrowed my wife's iPhone and generated the token.

Also working for me too. Feels like there may be a replication delay within Tesla after changing the password. Just have to be a little more patient I suppose.

All good now.


I experienced that it would not accept my 2FA. I have 2 2FA devices attached to my tesla.com account. I deleted one of the devices so only one were left - and then I could create a v3 token using 2FA.

Just checked again, and all working fine now.

Same error. No 2FA. Changed password and can now login using that new password via Chrome and via phone app but still unable to generate token.


Edit: Now it's working :)

I've tried to get a new token and got the message "Failed to get access token"

But it shows me a token.

No 2-Factor enabled.

Same error message, and I do have 2FA enabled (enabled before trying to refresh the token)



I have attempted to update to the v3 token but the Generate My Token link reports "Credentials Not Accepted By Tesla".

I have logged into my Tesla account with the same credentials and I have reset the password as recommended by the TeslaFi error page. 

I don't have 2-factor authentication enabled on my account.

Could you please recommend what to try next?


go to https://mfa.tesla.com - you need to installa an authenticator app on a device. Search either Google Play store or Apple Appstore for "Authenticator" and find a vender who you like/trust. Google and Microsoft among others are valid authenticators.